dmenu-q-xywh-xft-git/PKGBUILD

41 lines
949 B
Bash

# Maintainer: Jack L. Frost <fbt@fleshless.org>
# % Trigger: 1433749514 %
_pkgname='dmenu-q-xywh-xft'
pkgname="${_pkgname}-git"
pkgver=r4.a9e4948
pkgrel=1
pkgdesc='Dynamic X menu - with the xft and q-xywh patches applied'
arch=( 'i686' 'x86_64' )
url="https://github.com/baskerville/${_pkgname}"
license=( 'MIT' )
depends=( 'libxinerama' 'libxft')
makedepends=( 'git' )
provides=( 'dmenu' )
conflicts=( 'dmenu' )
source=( "git+https://github.com/baskerville/${_pkgname}.git" )
pkgver() {
cd "$_pkgname"
if git_version=$( git describe --long --tags 2>/dev/null ); then
IFS='-' read last_tag tag_rev commit <<< "$git_version"
printf '%s.r%s.%s' "$last_tag" "$tag_rev" "$commit"
else
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
fi
}
build() {
cd "$srcdir/$_pkgname"
make PREFIX=/usr
}
package() {
cd "$srcdir/$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
}
md5sums=( 'SKIP' )