fbt
f76f41f614
All checks were successful
Package builder / BuildPackage (push) Successful in 41s
Signed-off-by: fbt <fbt@fleshless.org>
32 lines
773 B
Bash
32 lines
773 B
Bash
# Maintainer: Jack Frost <fbt@fleshless.org>
|
|
# Random string
|
|
|
|
pkgdesc='Package for sysvinit compatibility'
|
|
pkgname=( 'sinit-sysvcompat' 'sinit-tools' )
|
|
license=( 'ISC' )
|
|
pkgver=1.0.6
|
|
pkgrel=5
|
|
arch=( 'any' )
|
|
url='https://code.fleshless.org/spark/sinit-tools'
|
|
|
|
conflicts=( 'systemd-sysvcompat' )
|
|
|
|
source=( "https://code.fleshless.org/Spark/sinit-tools/archive/$pkgver.tar.gz" )
|
|
|
|
package_sinit-sysvcompat() {
|
|
depends=( 'sinit' 'sinit-tools' )
|
|
|
|
mkdir -pm755 "${pkgdir}/usr/bin"
|
|
ln -s sinit "${pkgdir}/usr/bin/init"
|
|
ln -s shutdown "${pkgdir}/usr/bin/reboot"
|
|
ln -s shutdown "${pkgdir}/usr/bin/poweroff"
|
|
}
|
|
|
|
package_sinit-tools() {
|
|
depends=( 'sinit' )
|
|
|
|
install -Dm755 "$pkgname/shutdown" "${pkgdir}/usr/bin/shutdown"
|
|
}
|
|
|
|
sha1sums=('96548925c0b4c649d0c2f5940fd29a3b221a8909')
|