patch for linux build

Signed-off-by: fbt <fbt@fleshless.org>
This commit is contained in:
Jack L. Frost 2024-01-16 14:12:10 +00:00
parent c55b7c24fe
commit 685fc97382
2 changed files with 26 additions and 9 deletions

View File

@ -0,0 +1,11 @@
--- smdev.c 2014-09-29 10:55:09.000000000 +0000
+++ smdev.c.fixed 2024-01-16 14:06:19.054325378 +0000
@@ -1,7 +1,7 @@
/* See LICENSE file for copyright and license details. */
#include <sys/ioctl.h>
#include <sys/stat.h>
-#include <sys/types.h>
+#include <sys/sysmacros.h>
#include <linux/sockios.h>
#include <linux/if_packet.h>

View File

@ -1,5 +1,4 @@
# Maintainer: Jack L. Frost <fbt@fleshless.org>
# vim: ts=2 sw=2 et:
pkgname=smdev
pkgver=0.2.3
@ -11,22 +10,29 @@ license=( 'MIT/X' )
options=( 'strip' )
install='smdev.install'
source=(
"https://dl.suckless.org/smdev/smdev-$pkgver.tar.gz"
'smdev.install'
'config.h'
"https://dl.suckless.org/smdev/smdev-$pkgver.tar.gz"
'0001-fix-linux-build.patch'
'smdev.install'
'config.h'
)
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch --forward --input="${srcdir}/0001-fix-linux-build.patch"
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
ln -fs ../config.h
make
cd "${srcdir}/${pkgname}-${pkgver}"
ln -fs ../config.h
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make PREFIX=/usr DESTDIR="$pkgdir/" install
cd "${srcdir}/${pkgname}-${pkgver}"
make PREFIX=/usr DESTDIR="$pkgdir/" install
}
sha1sums=('2154fbf82da58fdd4d38fb72025719405650d7e0'
'9d1021bd5092e1b3e229c317188f562a13c213ea'
'dff00e0f4fd06148b56eee1ab769b0fd976ed4eb'
'd48c01140bf0c414fa81399963d47488670da7f0')