v++
Signed-off-by: fbt <fbt@fleshless.org>
This commit is contained in:
parent
452eae776f
commit
5c607922ba
|
@ -1,17 +1,90 @@
|
||||||
|
From f7d07e298c819a81eab965efbdbf53a2ce67fc0e Mon Sep 17 00:00:00 2001
|
||||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||||
Date: Tue, 6 Mar 2018 23:39:47 +0100
|
Date: Tue, 6 Mar 2018 23:39:47 +0100
|
||||||
Subject: [PATCH] Use Arch Linux' device access groups
|
Subject: [PATCH] Use Arch Linux' device access groups
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
cdrom → optical
|
cdrom → optical
|
||||||
dialout → uucp
|
dialout → uucp
|
||||||
tape → storage
|
tape → storage
|
||||||
---
|
---
|
||||||
|
meson.build | 6 +++---
|
||||||
|
meson_options.txt | 12 ++++++------
|
||||||
rules.d/50-udev-default.rules.in | 14 +++++++-------
|
rules.d/50-udev-default.rules.in | 14 +++++++-------
|
||||||
sysusers.d/basic.conf.in | 6 +++---
|
sysusers.d/basic.conf.in | 6 +++---
|
||||||
2 files changed, 10 insertions(+), 10 deletions(-)
|
4 files changed, 19 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 32e5413a62..f781e06fed 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -796,19 +796,19 @@ conf.set_quoted('NOBODY_GROUP_NAME', nobody_group)
|
||||||
|
static_ugids = []
|
||||||
|
foreach option : ['adm-gid',
|
||||||
|
'audio-gid',
|
||||||
|
- 'cdrom-gid',
|
||||||
|
- 'dialout-gid',
|
||||||
|
'disk-gid',
|
||||||
|
'input-gid',
|
||||||
|
'kmem-gid',
|
||||||
|
'kvm-gid',
|
||||||
|
'lp-gid',
|
||||||
|
+ 'optical-gid',
|
||||||
|
'render-gid',
|
||||||
|
'sgx-gid',
|
||||||
|
- 'tape-gid',
|
||||||
|
+ 'storage-gid',
|
||||||
|
'tty-gid',
|
||||||
|
'users-gid',
|
||||||
|
'utmp-gid',
|
||||||
|
+ 'uucp-gid',
|
||||||
|
'video-gid',
|
||||||
|
'wheel-gid',
|
||||||
|
'systemd-journal-gid',
|
||||||
|
diff --git a/meson_options.txt b/meson_options.txt
|
||||||
|
index 5048de755d..676e5e2e0d 100644
|
||||||
|
--- a/meson_options.txt
|
||||||
|
+++ b/meson_options.txt
|
||||||
|
@@ -235,10 +235,6 @@ option('adm-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "adm" group')
|
||||||
|
option('audio-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "audio" group')
|
||||||
|
-option('cdrom-gid', type : 'integer', value : '-1',
|
||||||
|
- description : 'soft-static allocation for the "cdrom" group')
|
||||||
|
-option('dialout-gid', type : 'integer', value : '-1',
|
||||||
|
- description : 'soft-static allocation for the "dialout" group')
|
||||||
|
option('disk-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "disk" group')
|
||||||
|
option('input-gid', type : 'integer', value : '-1',
|
||||||
|
@@ -249,18 +245,22 @@ option('kvm-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "kvm" group')
|
||||||
|
option('lp-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "lp" group')
|
||||||
|
+option('optical-gid', type : 'integer', value : '-1',
|
||||||
|
+ description : 'soft-static allocation for the "optical" group')
|
||||||
|
option('render-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "render" group')
|
||||||
|
option('sgx-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "sgx" group')
|
||||||
|
-option('tape-gid', type : 'integer', value : '-1',
|
||||||
|
- description : 'soft-static allocation for the "tape" group')
|
||||||
|
+option('storage-gid', type : 'integer', value : '-1',
|
||||||
|
+ description : 'soft-static allocation for the "storage" group')
|
||||||
|
option('tty-gid', type : 'integer', value : 5,
|
||||||
|
description : 'the numeric GID of the "tty" group')
|
||||||
|
option('users-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "users" group')
|
||||||
|
option('utmp-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "utmp" group')
|
||||||
|
+option('uucp-gid', type : 'integer', value : '-1',
|
||||||
|
+ description : 'soft-static allocation for the "uucp" group')
|
||||||
|
option('video-gid', type : 'integer', value : '-1',
|
||||||
|
description : 'soft-static allocation for the "video" group')
|
||||||
|
option('wheel-gid', type : 'integer', value : '-1',
|
||||||
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
|
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
|
||||||
index 191f56f42..f81c4d0fc 100644
|
index 18a3cf46bf..f3c440fd89 100644
|
||||||
--- a/rules.d/50-udev-default.rules.in
|
--- a/rules.d/50-udev-default.rules.in
|
||||||
+++ b/rules.d/50-udev-default.rules.in
|
+++ b/rules.d/50-udev-default.rules.in
|
||||||
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
|
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
|
||||||
|
@ -23,7 +96,7 @@ index 191f56f42..f81c4d0fc 100644
|
||||||
|
|
||||||
SUBSYSTEM=="mem", KERNEL=="mem|kmem|port", GROUP="kmem", MODE="0640"
|
SUBSYSTEM=="mem", KERNEL=="mem|kmem|port", GROUP="kmem", MODE="0640"
|
||||||
|
|
||||||
@@ -57,13 +57,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
|
@@ -67,13 +67,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
|
||||||
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:*", GROUP="lp"
|
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:*", GROUP="lp"
|
||||||
|
|
||||||
SUBSYSTEM=="block", GROUP="disk"
|
SUBSYSTEM=="block", GROUP="disk"
|
||||||
|
@ -44,24 +117,27 @@ index 191f56f42..f81c4d0fc 100644
|
||||||
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
|
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
|
||||||
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
|
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
|
||||||
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
|
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
|
||||||
index 8e358c02d..33e513a36 100644
|
index 8cc1a7cad2..21bb6d8948 100644
|
||||||
--- a/sysusers.d/basic.conf.in
|
--- a/sysusers.d/basic.conf.in
|
||||||
+++ b/sysusers.d/basic.conf.in
|
+++ b/sysusers.d/basic.conf.in
|
||||||
@@ -24,14 +24,14 @@ g utmp - - -
|
@@ -22,17 +22,17 @@ g utmp {{UTMP_GID }} - -
|
||||||
|
|
||||||
# Hardware access groups
|
# Physical and virtual hardware access groups
|
||||||
g audio - - -
|
g audio {{AUDIO_GID }} - -
|
||||||
-g cdrom - - -
|
-g cdrom {{CDROM_GID }} - -
|
||||||
-g dialout - - -
|
-g dialout {{DIALOUT_GID}} - -
|
||||||
g disk - - -
|
g disk {{DISK_GID }} - -
|
||||||
g input - - -
|
g input {{INPUT_GID }} - -
|
||||||
g kvm - - -
|
g kmem {{KMEM_GID }} - -
|
||||||
g lp - - -
|
g kvm {{KVM_GID }} - -
|
||||||
+g optical - - -
|
g lp {{LP_GID }} - -
|
||||||
g render - - -
|
+g optical {{OPTICAL_GID}} - -
|
||||||
-g tape - - -
|
g render {{RENDER_GID }} - -
|
||||||
+g storage - - -
|
g sgx {{SGX_GID }} - -
|
||||||
+g uucp - - -
|
-g tape {{TAPE_GID }} - -
|
||||||
g video - - -
|
+g storage {{STORAGE_GID}} - -
|
||||||
|
g tty {{TTY_GID }} - -
|
||||||
|
+g uucp {{UUCP_GID }} - -
|
||||||
|
g video {{VIDEO_GID }} - -
|
||||||
|
|
||||||
# Default group for normal users
|
# Default group for normal users
|
||||||
|
|
25
PKGBUILD
25
PKGBUILD
|
@ -3,9 +3,9 @@
|
||||||
|
|
||||||
pkgbase=systemd-libs
|
pkgbase=systemd-libs
|
||||||
pkgname=('systemd-libs-systemd' 'systemd-libs-udev')
|
pkgname=('systemd-libs-systemd' 'systemd-libs-udev')
|
||||||
_tag='5ca6cc7f6e95bd98bb014126040d4a5fae541511' # git rev-parse v${pkgver}
|
_tag='f1d37a5c491d85255e9996960dc2889a15022b78' # git rev-parse v${pkgver}
|
||||||
pkgver=247.3
|
pkgver=249.1
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://www.github.com/systemd/systemd'
|
url='https://www.github.com/systemd/systemd'
|
||||||
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
|
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
|
||||||
|
@ -13,15 +13,20 @@ makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
|
||||||
'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
|
'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
|
||||||
'python-lxml' 'quota-tools' 'shadow' 'gnu-efi-libs' 'git'
|
'python-lxml' 'quota-tools' 'shadow' 'gnu-efi-libs' 'git'
|
||||||
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
|
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
|
||||||
'bash-completion' 'p11-kit')
|
'bash-completion' 'p11-kit' 'python-jinja')
|
||||||
options=('strip')
|
options=('strip')
|
||||||
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
|
#validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
|
||||||
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
|
# '5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
|
||||||
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
|
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}"
|
||||||
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
|
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}"
|
||||||
'0001-Use-Arch-Linux-device-access-groups.patch')
|
'0001-Use-Arch-Linux-device-access-groups.patch')
|
||||||
|
|
||||||
_backports=(
|
_backports=(
|
||||||
|
# coredumpctl: stop truncating information about coredump
|
||||||
|
'473627e1c9fcdf8f819ced2bb79cb7e9ff598b0c'
|
||||||
|
|
||||||
|
# Revert "core: Check unit start rate limiting earlier"
|
||||||
|
'4fa9d8f14523982482386d398d2b2669902f2098'
|
||||||
)
|
)
|
||||||
|
|
||||||
_reverts=(
|
_reverts=(
|
||||||
|
@ -131,6 +136,4 @@ package_systemd-libs-udev() {
|
||||||
|
|
||||||
sha1sums=('SKIP'
|
sha1sums=('SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'db7ac1d9b083d5d48230fd194477f32ab497a0b3')
|
'3d1f12e3d9a1eea63964f598b3e8334b9a9f1528')
|
||||||
|
|
||||||
# vim:ft=sh syn=sh et sw=2:
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user