v++
Signed-off-by: fbt <fbt@fleshless.org>
This commit is contained in:
parent
1005958fa8
commit
772822a497
|
@ -1,7 +1,10 @@
|
|||
From f7d07e298c819a81eab965efbdbf53a2ce67fc0e Mon Sep 17 00:00:00 2001
|
||||
From 0e8c18bc2639da328274d02d9222ee2c1f6bf696 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Tue, 6 Mar 2018 23:39:47 +0100
|
||||
Subject: [PATCH] Use Arch Linux' device access groups
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
cdrom → optical
|
||||
dialout → uucp
|
||||
|
@ -14,10 +17,10 @@ Subject: [PATCH] Use Arch Linux' device access groups
|
|||
4 files changed, 19 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 32e5413a62..f781e06fed 100644
|
||||
index 76ad51d3fb..5cf679b088 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -796,19 +796,19 @@ conf.set_quoted('NOBODY_GROUP_NAME', nobody_group)
|
||||
@@ -915,19 +915,19 @@ conf.set_quoted('NOBODY_GROUP_NAME', nobody_group)
|
||||
static_ugids = []
|
||||
foreach option : ['adm-gid',
|
||||
'audio-gid',
|
||||
|
@ -41,50 +44,50 @@ index 32e5413a62..f781e06fed 100644
|
|||
'wheel-gid',
|
||||
'systemd-journal-gid',
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 5048de755d..676e5e2e0d 100644
|
||||
index 814f340840..253a77ecb3 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -235,10 +235,6 @@ option('adm-gid', type : 'integer', value : '-1',
|
||||
@@ -257,10 +257,6 @@ option('adm-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "adm" group')
|
||||
option('audio-gid', type : 'integer', value : '-1',
|
||||
option('audio-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "audio" group')
|
||||
-option('cdrom-gid', type : 'integer', value : '-1',
|
||||
-option('cdrom-gid', type : 'integer', value : 0,
|
||||
- description : 'soft-static allocation for the "cdrom" group')
|
||||
-option('dialout-gid', type : 'integer', value : '-1',
|
||||
-option('dialout-gid', type : 'integer', value : 0,
|
||||
- description : 'soft-static allocation for the "dialout" group')
|
||||
option('disk-gid', type : 'integer', value : '-1',
|
||||
option('disk-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "disk" group')
|
||||
option('input-gid', type : 'integer', value : '-1',
|
||||
@@ -249,18 +245,22 @@ option('kvm-gid', type : 'integer', value : '-1',
|
||||
option('input-gid', type : 'integer', value : 0,
|
||||
@@ -271,18 +267,22 @@ option('kvm-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "kvm" group')
|
||||
option('lp-gid', type : 'integer', value : '-1',
|
||||
option('lp-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "lp" group')
|
||||
+option('optical-gid', type : 'integer', value : '-1',
|
||||
+option('optical-gid', type : 'integer', value : '0',
|
||||
+ description : 'soft-static allocation for the "optical" group')
|
||||
option('render-gid', type : 'integer', value : '-1',
|
||||
option('render-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "render" group')
|
||||
option('sgx-gid', type : 'integer', value : '-1',
|
||||
option('sgx-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "sgx" group')
|
||||
-option('tape-gid', type : 'integer', value : '-1',
|
||||
-option('tape-gid', type : 'integer', value : 0,
|
||||
- description : 'soft-static allocation for the "tape" group')
|
||||
+option('storage-gid', type : 'integer', value : '-1',
|
||||
+option('storage-gid', type : 'integer', value : '0',
|
||||
+ description : 'soft-static allocation for the "storage" group')
|
||||
option('tty-gid', type : 'integer', value : 5,
|
||||
description : 'the numeric GID of the "tty" group')
|
||||
option('users-gid', type : 'integer', value : '-1',
|
||||
option('users-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "users" group')
|
||||
option('utmp-gid', type : 'integer', value : '-1',
|
||||
option('utmp-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "utmp" group')
|
||||
+option('uucp-gid', type : 'integer', value : '-1',
|
||||
+option('uucp-gid', type : 'integer', value : '0',
|
||||
+ description : 'soft-static allocation for the "uucp" group')
|
||||
option('video-gid', type : 'integer', value : '-1',
|
||||
option('video-gid', type : 'integer', value : 0,
|
||||
description : 'soft-static allocation for the "video" group')
|
||||
option('wheel-gid', type : 'integer', value : '-1',
|
||||
option('wheel-gid', type : 'integer', value : 0,
|
||||
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
|
||||
index 18a3cf46bf..f3c440fd89 100644
|
||||
index 843bdaf9ce..a192f091df 100644
|
||||
--- a/rules.d/50-udev-default.rules.in
|
||||
+++ b/rules.d/50-udev-default.rules.in
|
||||
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
|
||||
@@ -26,7 +26,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
|
||||
SUBSYSTEM=="tty", KERNEL=="ttysclp[0-9]*", GROUP="tty", MODE="0620"
|
||||
SUBSYSTEM=="tty", KERNEL=="3270/tty[0-9]*", GROUP="tty", MODE="0620"
|
||||
SUBSYSTEM=="vc", KERNEL=="vcs*|vcsa*", GROUP="tty"
|
||||
|
@ -93,7 +96,7 @@ index 18a3cf46bf..f3c440fd89 100644
|
|||
|
||||
SUBSYSTEM=="mem", KERNEL=="mem|kmem|port", GROUP="kmem", MODE="0640"
|
||||
|
||||
@@ -67,13 +67,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
|
||||
@@ -72,13 +72,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
|
||||
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:*", GROUP="lp"
|
||||
|
||||
SUBSYSTEM=="block", GROUP="disk"
|
||||
|
@ -114,10 +117,10 @@ index 18a3cf46bf..f3c440fd89 100644
|
|||
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
|
||||
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
|
||||
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
|
||||
index 8cc1a7cad2..21bb6d8948 100644
|
||||
index a602b872e4..8d38febb6a 100644
|
||||
--- a/sysusers.d/basic.conf.in
|
||||
+++ b/sysusers.d/basic.conf.in
|
||||
@@ -22,17 +22,17 @@ g utmp {{UTMP_GID }} - -
|
||||
@@ -23,17 +23,17 @@ g utmp {{UTMP_GID }} - -
|
||||
|
||||
# Physical and virtual hardware access groups
|
||||
g audio {{AUDIO_GID }} - -
|
||||
|
@ -138,10 +141,12 @@ index 8cc1a7cad2..21bb6d8948 100644
|
|||
g video {{VIDEO_GID }} - -
|
||||
|
||||
# Default group for normal users
|
||||
From 14de5ced41edc9fa8e380330c03adc89ef257fbc Mon Sep 17 00:00:00 2001
|
||||
|
||||
From 9e2987a7b4d09d7b554141e9ef2c911cb3fda570 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Mon, 27 Dec 2021 23:32:42 +0100
|
||||
Subject: [PATCH] generate tmpfiles.d/legacy.conf
|
||||
|
||||
---
|
||||
tmpfiles.d/legacy.conf.in | 3 ---
|
||||
tmpfiles.d/meson.build | 2 +-
|
||||
|
@ -162,10 +167,10 @@ index 4f2c0d7c43..62e2ae0986 100644
|
|||
# /run/lock/subsys is used for serializing SysV service execution, and
|
||||
# hence without use on SysV-less systems.
|
||||
diff --git a/tmpfiles.d/meson.build b/tmpfiles.d/meson.build
|
||||
index b8d3919025..000bd0bd22 100644
|
||||
index ca1abbf3fe..25e2b53402 100644
|
||||
--- a/tmpfiles.d/meson.build
|
||||
+++ b/tmpfiles.d/meson.build
|
||||
@@ -27,7 +27,7 @@ foreach pair : files
|
||||
@@ -29,7 +29,7 @@ foreach pair : files
|
||||
endforeach
|
||||
|
||||
in_files = [['etc.conf', ''],
|
||||
|
|
Loading…
Reference in New Issue
Block a user