Signed-off-by: fbt <fbt@fleshless.org>
This commit is contained in:
Jack L. Frost 2021-01-24 14:07:58 +03:00
parent 40f128f1f7
commit acfcf09c62
2 changed files with 39 additions and 46 deletions

View File

@ -1,24 +1,19 @@
From 34e4b4953cb99642e9144d97823edf32b06ffe93 Mon Sep 17 00:00:00 2001
Message-Id: <34e4b4953cb99642e9144d97823edf32b06ffe93.1520376078.git.jan.steffens@gmail.com>
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 6 Mar 2018 23:39:47 +0100
Subject: [PATCH] Use Arch Linux' device access groups
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
cdrom → optical
dialout → uucp
tape → storage
---
rules/50-udev-default.rules.in | 14 +++++++-------
rules.d/50-udev-default.rules.in | 14 +++++++-------
sysusers.d/basic.conf.in | 6 +++---
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/rules/50-udev-default.rules.in b/rules/50-udev-default.rules.in
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
index 191f56f42..f81c4d0fc 100644
--- a/rules/50-udev-default.rules.in
+++ b/rules/50-udev-default.rules.in
--- a/rules.d/50-udev-default.rules.in
+++ b/rules.d/50-udev-default.rules.in
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
SUBSYSTEM=="tty", KERNEL=="ttysclp[0-9]*", GROUP="tty", MODE="0620"
SUBSYSTEM=="tty", KERNEL=="3270/tty[0-9]*", GROUP="tty", MODE="0620"
@ -70,6 +65,3 @@ index 8e358c02d..33e513a36 100644
g video - - -
# Default group for normal users
--
2.16.2

View File

@ -1,31 +1,36 @@
# Maintainer: Christian Hesse <mail@eworm.de>
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Tom Gundersen <teg@jklm.no>
# Stripped by fbt@fleshless.org to only provide the libs.
pkgbase=systemd
pkgbase=systemd-libs
pkgname=('systemd-libs-systemd' 'systemd-libs-udev')
# Can be from either systemd or systemd-stable
_commit='a09c170122cf3b37c3e4431bf082f9dbdc07fc70'
pkgver=243.78
_tag='8dff57da7abcb15e69936a8af9780475eb961a73' # git rev-parse v${pkgver}
pkgver=247.2
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn2' 'libgcrypt'
'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow' 'gnu-efi-libs' 'git'
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
'bash-completion')
'bash-completion' 'p11-kit')
options=('strip')
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
source=(# fragment is latest tag for source verification, final merge in prepare()
"git+https://github.com/systemd/systemd-stable#tag=v${pkgver%.*}?signed"
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
'0001-Use-Arch-Linux-device-access-groups.patch')
_backports=(
# set: introduce set_strjoin()
'4dbce717873000cff7b56f89266d1d2fe53f9284'
# sd-device: use set_strjoin()
'6f3ac0d51766b0b9101676cefe5c4ba81feba436'
# sd-device: keep escaped strings in DEVLINK= property
'31063db0b4842a452c6eadde5b969aaee2a0516a'
# test: add tests for device_new_from_nulstr()
'e6f882871568e4a331ac473871ee8a884f6e48d6'
)
_reverts=(
@ -36,15 +41,14 @@ prepare() {
# add upstream repository for cherry-picking
git remote add -f upstream ../systemd
# merge the latest stable commit (fast-foward only to make sure
# the verified tag is in)
git merge --ff-only "${_commit}"
local _c
for _c in "${_backports[@]}"; do
git log --oneline -1 "${_c}"
git cherry-pick -n "${_c}"
done
for _c in "${_reverts[@]}"; do
git log --oneline -1 "${_c}"
git revert -n "${_c}"
done
@ -52,15 +56,6 @@ prepare() {
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
}
pkgver() {
cd "systemd-stable"
local _version _count
_version="$(git describe --abbrev=0 --tags)"
_count="$(git rev-list --count ${_version}..)"
printf '%s.%s' "${_version#v}" "${_count}"
}
build() {
local _timeservers=({0..3}.arch.pool.ntp.org)
local _nameservers=(
@ -79,17 +74,25 @@ build() {
local _meson_options=(
-Dversion-tag="${pkgver}-${pkgrel}-arch"
-Dmode=release
-Dgnu-efi=true
-Dima=false
-Dlibidn2=true
-Dlz4=true
-Dman=true
# We disable DNSSEC by default, it still causes trouble:
# https://github.com/systemd/systemd/issues/10579
-Ddbuspolicydir=/usr/share/dbus-1/system.d
-Ddefault-dnssec=no
-Ddefault-hierarchy=hybrid
-Ddefault-locale=C
-Ddefault-kill-user-processes=false
-Ddefault-locale=C
-Ddns-over-tls=openssl
-Dfallback-hostname='archlinux'
-Dnologin-path=/usr/bin/nologin
-Dntp-servers="${_timeservers[*]}"
-Ddns-servers="${_nameservers[*]}"
-Drpmmacrosdir=no
@ -97,28 +100,25 @@ build() {
-Dsysvrcnd-path=
)
arch-meson "systemd-stable" build "${_meson_options[@]}"
arch-meson "$pkgbase-stable" build "${_meson_options[@]}"
ninja -C build
}
#check() {
# meson test -C build
#}
#check() { meson test -C build; }
package_systemd-libs-systemd() {
pkgdesc='systemd client libraries'
depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz')
depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz' 'zstd')
license=('LGPL2.1')
provides=('libsystemd' 'libsystemd.so' 'systemd-libs')
conflicts=('libsystemd' 'systemd-libs' 'libsystemd-standalone')
replaces=('libsystemd' 'libsystemd-standalone')
provides=('libsystemd' 'libsystemd.so' 'libudev.so')
conflicts=('libsystemd')
replaces=('libsystemd')
DESTDIR="$srcdir/full-install" meson install -C build
# runtime libraries shipped with systemd-libs
install -d -m0755 "$pkgdir"/usr/lib
mv "$srcdir/full-install/usr/lib/"lib{nss,systemd}*.so* "$pkgdir/usr/lib/"
cp --archive "$srcdir/full-install/usr/lib/"lib{nss,systemd}*.so* "$pkgdir/usr/lib/"
}
package_systemd-libs-udev() {
@ -132,7 +132,8 @@ package_systemd-libs-udev() {
cp --archive "$srcdir/full-install/usr/lib/"libudev* "$pkgdir/usr/lib/"
}
# vim:ft=sh syn=sh et sw=2:
sha1sums=('SKIP'
'SKIP'
'35da29351a3aae0d30579e271adb14a1ae23a9c4')
'db7ac1d9b083d5d48230fd194477f32ab497a0b3')
# vim:ft=sh syn=sh et sw=2: